PHPのバージョンを、特定のフォルダだけ変える

メインサイトは、Xoops2.1で構築されれて、部分的にwordpress、
xoopsのアップグレードがめんどくさくて、phpのバージョンも古いまま(5.2)にしていました。
そこでいざwordpressのアップグレードをしようとすると、PHPのバージョンが古くてできない!
しかし、サーバーの設定でバージョンをあげてしまうと、xoopsが対応できない!
なんとかならないかと思っていたら、良い方法があるではないですか。

<参考サイト様>ありがとうございます!!
ディレクトリごとに異なるPHPバージョンを動作させる
https://dp778.co.jp/archives/cpt_blog/2875/
異なるバージョンのPHPを使う
http://qiita.com/akspect/items/3231a957f7af8471efb7

この方法で、wordpressがインストールされているディレクトリに、php.cgiを入れたらできましたー
無事、最新のwordpressをインストールできました。
xoopsはそのままに。